Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Помогите. Надо решить через pascal.

5-9 класс

20Liza00 05 мая 2013 г., 22:45:28 (11 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Akadno
06 мая 2013 г., 0:37:52 (11 лет назад)

1)

 

var
s: string;
count, i: integer;
begin
readln(s);
for i := 1 to length(s) do
if(s[i] = '4') or (s[i] = '5') then inc(count);
writeln('Кол-во цифр "4" и "5" в тексте: ', count);
end.

 

2)

 

var
x, y: integer;
begin
writeln('Введите x, y: '); readln(x, y);
if(x mod y = 0) then writeln('Является делителем')
else writeln('Не является делителем');
end.

 

3)

 

var
a, b, c: integer;
begin
writeln('Введите стороны треугольника: '); readln(a, b, c);
if(abs(a - b) < c) and (c < (a + b)) then writeln('Это не треугольник')
else writeln('Это треугольник');
end.

 

4)

 

var
s, sout: string;
i: integer;
begin
s := 'информатика';
for i := 3 to 8 do
sout := sout + s[i];
writeln(sout);
end.

 

p.s насчет 4 - не уверен.

 

 

Ответить

Другие вопросы из категории

Плиз!!Фантазии ноль :(((

Придумайте загадки сами для понятий "телефон", "стол", "диск", "записная книжка", "мышь", "школа".

написать отчет по паскалю
тренажер для изучения логических элементов

Как пройти +

Читайте также

Помогите пожалуйсто решить прошу очень срочно!!!!

1. Чему равны значения переменных r, a, d?
a:=5; b:=20; c:=-7;
d:=2.5;
r := a+(4*b+c)*d;
a:= a+4;
d:=a*7;

2. В пяти тестовых опросах мальчик получил оценки. Составьте программу, которая определит среднее значение оценок, полученных мальчиком в пяти опросах.

3*. Задача. «Покупка в магазине»
Человек делает в магазине покупки. Определите сколько денег у него останется после покупки в магазине перчаток стоимостью А руб., портфеля стоимостью B руб. и галстука стоимостью D руб. Все исходные данные задаются с клавиатуры.

Исходные данные.
a — стоимость перчаток;
b — стоимость портфеля;
d — стоимость галстука;
dengi — количество денег у человека.
Все эти переменные будут вещественного типа.
Результат.
ostatok — количество денег, которое останется у человек (вещественный тип).
Метод решения.
ostatok = dengi – a – b – d
Написать программу, реализующую данную задачу
Помогите пожалуйсто решить очень срочно!!!!!!

помогите плиз капец как надо ваще не могу решить плиззз

надо решить 10,11,12,13

Пожалуйста!решите!умоляю!

К берегу реки, где была лодка, вмещающая только 2 человек, подошли 2 разбойника и 2 путешественника. Разбойники не решались напасть на путешественников. В случае если на берегу останется 1 путешественник и 2 разбойник то они нападут на него. Как надо переправится через реку разбой и путешественник чтоб последние не смогли избежать нападения?

1.Если данное натурального число меньше 10, то прибавьте 10, иначе вычьте. Решить через Паскаль var, begin-end. 2. Дано трехзначное число.

Верно ли, что его первая цифра меньше последней? Решить также. Помогите пожалуйста!



Вы находитесь на странице вопроса "Помогите. Надо решить через pascal.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.