Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 981 ответов!

Напишите для паскаля,пожалуйста.

5-9 класс

С клавиатуры вводятся 17 чисел. Найти произведение положительных чисел не делящихся на 17.
(Мы прошли только до цикла с постусловием)

Fedorihevaaman 23 февр. 2014 г., 5:02:20 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Aem7s
23 февр. 2014 г., 5:52:07 (10 лет назад)

Program chik;
var k,i,s,a:integer;
begin
s:=1;k:=0;
for i:=1 to 17 do
begin
read(a);
if (a mod 17<>0)then begin
k:=1;
s:=s*i;
end;
end;
if k=1 then  write(s)else write(0);
end.
вроде так

+ 0 -
Lerka222
23 февр. 2014 г., 7:37:45 (10 лет назад)

var
  p, i, t : integer;
begin
  p := 1;
  i := 1;
  repeat 
    read (t);
    if t mod 17 <> 0 then p := p * t;
    i := i + 1;
  until i > 17;
write (p);
end.

Ответить

Другие вопросы из категории

Продолжите фрызы

1) Файл
2) Пользователь
3)Пользовательский интерфейс

Разгадайте анаграммы

1. АТОАРСРВЯ
2. ПРАЕТРМА
3. ЕТРАВКОНЯ
4. РКАЬАФАТЛНЯ


Найдите зашифрованные в сканворде понятия информатики

Читайте также

Напишите для паскаля,пожалуйста.

С клавиатуры вводятся 17 чисел. Найти произведение положительных чисел не делящихся на 17.

Определить Лежит ли точка в заштрихованной плоскости.

Напишите в Паскале пожалуйста

НАПИШИТЕ ПОЖАЛУЙСТА ПРОГРАММУ ДЛЯ ПАСКАЛЯ: 1) Разработайте алгоритм для ввода в память ЭВМ линейной таблицы В, состоящей из 8 элементов вещественного

типа. Ввод организуйе без использования цикла 2) разработайте алгоритм для ввода в память ЭВМ одномерного массива С состоященр из 7 элементов целого тип. Ввод организуйе с исползованием цикла "ДЛЯ". 3) разработайте алгоритм для ввода в память ЭВМ одномерного массива Д состоящего из 10 элементов целого типа. Каждый элемнт вычислите по формуле: значение элемента равно квадрату его индекса

Пожалуйста! Напишите программу для паскаля-

Имеются два числа:
а) вычислите сумму и разность этих чисел, используя два оператора readln.
б) перепишите программу так, чтобы использовался один оператор readln.
в) добавьте комментарии к программе.



Вы находитесь на странице вопроса "Напишите для паскаля,пожалуйста.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.