Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

написать програму которая проверяет является ли целое число введенное пользователем- простым. ЭТО ТУРБО ПАСКАЛЬ, ЦИКЛ FOR<ПЛИЗ ОЧЕНЬ НААДО*))))

5-9 класс

Dianayakushevi 01 февр. 2014 г., 3:51:54 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Oldcommer
01 февр. 2014 г., 6:39:15 (10 лет назад)

Program SimpleNumber; 

Uses Crt; 

var i,f,n:integer;
begin
    write('Введите число:');
     readln(n);
     for i:=2 to trunc(sqrt(n)) do
if (n mod i)=0 then f:=1;
if (f=0) then write('Число Простое')

           else writeln('Число не является простым');
   readkey;
end.

+ 0 -
Pavia
01 февр. 2014 г., 9:19:45 (10 лет назад)

program qq;
var a,b:integer; 
begin

readln (b);

for a:=b div 10 then write("простое");
end;
иначе write ("не простое");

end;

write(а);

end.
я не уверен, что программа будет работать правильно(

Ответить

Читайте также

1. Даны два различных вещественных числа X и Y. Написать программу, возведения наименьшего из чисел в квадрат, наибольшего – в куб и нахождения среднего

арифметического полученных значений.
2. За весну Обломов похудел на p1 кг, за лето поправился на p2 кг, за осень похудел на p3 кг, за зиму поправился на p4 кг. Написать программу, определяющую, похудел или поправился за год Обломов.
3. Написать программу, которая определяет, является ли целое число четным двузначным числом.
4. Даны коэффициенты квадратного уравнения. Написать программу, определяющую его корни

Написать программу, которая проверяет, является ли введённая с

клавиатуры строка шестнадцатеричным числом. В Паскале.

Числа Фибоначчи строятся следующим образом: 1, 1, 2, 3, 5, …. В этой последовательности, начиная с третьего числа, каждый следующий член равен сумме двух

предыдущих. Получаем, что, например, шестое число равно 8, а десятое - 55.

Требуется написать программу, которая определяет, является ли заданное число числом Фибоначчи.

Составьте программу,которая определяет,является ли сумма цифр введенного целого трехзначного числа четным числом.

Пример ввода:567.
Пример вывода:сумма цифр числа 567-четное число



Вы находитесь на странице вопроса "написать програму которая проверяет является ли целое число введенное пользователем- простым. ЭТО ТУРБО ПАСКАЛЬ, ЦИКЛ FOR<ПЛИЗ ОЧЕНЬ НААДО*))))", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.